Usually the Layer Slider is running properly on any server, where the Joomla is working without any issue. It doesn't have any special requirement, so it should work on most of the servers.

PHP & Extensions

The minimum version number of PHP is 5.2.4+ or any higher version.
The PHP GD - Graphics Directory is also required. Usually it is enabled on the 99.9% of the servers.

MySQL

The required version is 5.0.4+.

Joomla

Layer Slider supports Joomla 2.5 and 3.x versions. Please note, that the official support of Joomla 2.5 versions ended in Dec, 2014, so it is recommended to use the latest version for newly created sites.